GitHub Advisoryadvisory · PyPI
GHSA-5pqf-rvm7-3wgw collective.contact.widget is vulnerable to cross-site scripting
MEDIUM
Official page ↗
- Aliases
- CVE-2022-4638
- Ecosystem
- PyPI
- Packages
- collective.contact.widget
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-707, CWE-79
- Reviewed
- 2022-12-29
Affected packages
• PyPI collective.contact.widget: < 1.13 → fixed in 1.13
Description
collective.contact.widget is an add-on is part of the collective.contact.* suite. A vulnerability classified as problematic was found in collective.contact.widget up to 1.12. This vulnerability affects the function title of the file src/collective/contact/widget/widgets.py. The manipulation leads to cross site scripting. The attack can be initiated remotely. The name of the patch is 5da36305ca7ed433782be8901c47387406fcda12. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-216496.
Related
Alias · CVE (1)
- CVE-2022-4638 A vulnerability classified as problematic was found in collective.contact.widget up to 1.12. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-4638 advisory
- https://github.com/collective/collective.contact.widget/commit/5da36305ca7ed433782be8901c47387406fcda12 web
- https://github.com/collective/collective.contact.widget package
- https://github.com/pypa/advisory-database/tree/main/vulns/collective-contact-widget/PYSEC-2022-42988.yaml web
- https://vuldb.com/?id.216496 web