GitHub Advisoryadvisory · Packagist
GHSA-5pqx-77vf-85rw Wikimedia Parsoid vulnerable to Cross-site Scripting (XSS)
MEDIUM
Official page ↗
- Aliases
- CVE-2021-30458
- Ecosystem
- Packagist
- Packages
- wikimedia/parsoid
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-06-07
Affected packages
• Packagist wikimedia/parsoid: >= 0.12, < 0.12.2 → fixed in 0.12.2
• Packagist wikimedia/parsoid: < 0.11.1 → fixed in 0.11.1
Description
An issue was discovered in Wikimedia Parsoid before 0.11.1 and 0.12.x before 0.12.2. An attacker can send crafted wikitext that Utils/WTUtils.php will transform by using a tag, bypassing sanitization steps, and potentially allowing for XSS.
Related
Alias · CVE (1)
- CVE-2021-30458 An issue was discovered in Wikimedia Parsoid before 0.11.1 and 0.12.x before 0.12.2. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-30458 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/wikimedia/parsoid/CVE-2021-30458.yaml web
- https://github.com/wikimedia/mediawiki-services-parsoid package
- https://phabricator.wikimedia.org/T279451 web
- https://security.gentoo.org/glsa/202107-40 web
- https://www.mediawiki.org/wiki/Parsoid web