GitHub Advisoryadvisory · Packagist

GHSA-5qp6-78pr-gv8c PHP OpenID Library Denial of Service vulnerability

HIGH Published 2022-05-17 Modified 2023-08-29 Official page ↗
Aliases
CVE-2013-4701
Ecosystem
Packagist
Packages
openid/php-openid, typo3/cms
Severity
High
Weaknesses
CWE-400
Reviewed
2023-08-29

Affected packages

• Packagist openid/php-openid: < 2.3.0 → fixed in 2.3.0 • Packagist typo3/cms: >= 6.2.0, < 6.2.6 → fixed in 6.2.6

Description

Auth/Yadis/XML.php in PHP OpenID Library 2.2.2 and earlier allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via XRDS data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

Related

Alias · CVE (1)

  • CVE-2013-4701 Auth/Yadis/XML.php in PHP OpenID Library 2.2.2 and earlier allows remote attackers to read arbitrary files, send HTTP requests to intranet… vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References