GitHub Advisoryadvisory · Maven

GHSA-5qpv-27q3-6484 Jenkins Violation Plugin allows Cross-Site Scripting (XSS)

MEDIUM Published 2022-04-23 Modified 2025-03-12 Official page ↗
Aliases
CVE-2012-4440
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:violations
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2025-03-12

Affected packages

• Maven org.jenkins-ci.plugins:violations: < 0.7.11 → fixed in 0.7.11

Description

Cross-site Scripting (XSS) in Jenkins main before 1.482 and LTS before 1.466.2 allows remote attackers to inject arbitrary web script or HTML in the Violations plugin.

Related

Alias · CVE (1)

  • CVE-2012-4440 Cross-site Scripting (XSS) in Jenkins main before 1.482 and LTS before 1.466.2 allows remote attackers to inject arbitrary web script or… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References