GitHub Advisoryadvisory · Maven

GHSA-5qwq-g2hx-r6f7 Hessian Lite for Apache Dubbo deserialization vulnerability

CRITICAL Published 2022-10-19 Modified 2022-10-20 Official page ↗
Aliases
CVE-2022-39198
Ecosystem
Maven
Packages
com.alibaba:hessian-lite, org.apache.dubbo:dubbo
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2022-10-19

Affected packages

• Maven com.alibaba:hessian-lite: < 3.2.13 → fixed in 3.2.13 • Maven org.apache.dubbo:dubbo: >= 2.7.0, < 2.7.18 → fixed in 2.7.18 • Maven org.apache.dubbo:dubbo: >= 3.0.0, < 3.0.12 → fixed in 3.0.12 • Maven org.apache.dubbo:dubbo: >= 3.1.0, < 3.1.1 → fixed in 3.1.1

Description

A deserialization vulnerability existed in dubbo hessian-lite 3.2.12 and its earlier versions, which could lead to malicious code execution. This issue affects Apache Dubbo 2.7.x version 2.7.17 and prior versions; Apache Dubbo 3.0.x version 3.0.11 and prior versions; Apache Dubbo 3.1.x version 3.1.0 and prior versions.

Related

Alias · CVE (1)

  • CVE-2022-39198 A deserialization vulnerability existed in dubbo hessian-lite 3.2.12 and its earlier versions, which could lead to malicious code execution. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References