GitHub Advisoryadvisory · Maven
GHSA-5qx5-vg5w-5mx3 Stored XSS vulnerability in Jenkins Badge Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2022-23108
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:badge
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-04-29
Affected packages
• Maven org.jenkins-ci.plugins:badge: < 1.9.1 → fixed in 1.9.1
Description
Jenkins Badge Plugin 1.9 and earlier does not escape the description and does not check for allowed protocols when creating a badge, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Related
Alias · CVE (1)
- CVE-2022-23108 Jenkins Badge Plugin 1.9 and earlier does not escape the description and does not check for allowed protocols when creating a badge,… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness