GitHub Advisoryadvisory · RubyGems

GHSA-5r2p-j47h-mhpg Rack vulnerable to Cross-site Scripting

MEDIUM Published 2018-11-15 Modified 2023-08-28 Official page ↗
Aliases
CVE-2018-16471
Ecosystem
RubyGems
Packages
rack
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• RubyGems rack: >= 2.0.0, < 2.0.6 → fixed in 2.0.6 • RubyGems rack: < 1.6.11 → fixed in 1.6.11

Description

There is a possible XSS vulnerability in Rack before 2.0.6 and 1.6.11. Carefully crafted requests can impact the data returned by the `scheme` method on `Rack::Request`. Applications that expect the scheme to be limited to 'http' or 'https' and do not escape the return value could be vulnerable to an XSS attack. Note that applications using the normal escaping mechanisms provided by Rails may not impacted, but applications that bypass the escaping mechanisms, or do not use them may be vulnerable.

Related

Alias · CVE (1)

  • CVE-2018-16471 There is a possible XSS vulnerability in Rack before 2.0.6 and 1.6.11. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References