GitHub Advisoryadvisory · PyPI

GHSA-5r4x-qc7q-vj27 Zope Cross-site scripting (XSS) vulnerability in ZMI pages

MEDIUM Published 2022-05-02 Modified 2024-11-21 Official page ↗
Aliases
CVE-2009-5145
Ecosystem
PyPI
Packages
Zope2
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-11-21

Affected packages

• PyPI Zope2: < 2.12.5 → fixed in 2.12.5

Description

Cross-site scripting (XSS) vulnerability in ZMI pages that use the manage_tabs_message in Zope 2.11.4, 2.11.2, 2.10.9, 2.10.7, 2.10.6, 2.10.5, 2.10.4, 2.10.2, 2.10.1, 2.12.

Related

Alias · CVE (1)

  • CVE-2009-5145 Cross-site scripting (XSS) vulnerability in ZMI pages that use the manage_tabs_message in Zope 2.11.4, 2.11.2, 2.10.9, 2.10.7, 2.10.6,… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References