GitHub Advisoryadvisory · Packagist
GHSA-5r66-vgc7-2mm3 Drupal Formatter Suite Vulnerable to Cross-Site Scripting (XSS) via Link Element Attributes
LOW
Official page ↗
- Aliases
- CVE-2025-31697
- Ecosystem
- Packagist
- Packages
- drupal/formatter_suite
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-04-02
Affected packages
• Packagist drupal/formatter_suite: < 2.1.0 → fixed in 2.1.0
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Formatter Suite allows Cross-Site Scripting (XSS).This issue affects Formatter Suite: from 0.0.0 before 2.1.0.
Related
Alias · CVE (1)
- CVE-2025-31697 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Formatter Suite allows… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness