GitHub Advisoryadvisory · PyPI
GHSA-5rp4-749p-vx26 Apache Airflow vulnerable to Use of Externally-Controlled Format String
HIGH
Official page ↗
- Aliases
- CVE-2022-40604
- Ecosystem
- PyPI
- Packages
- apache-airflow
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-134
- Reviewed
- 2022-09-22
Affected packages
• PyPI apache-airflow: >= 2.3.0, < 2.4.0rc1 → fixed in 2.4.0rc1
Description
In Apache Airflow 2.3.0 through 2.3.4, part of a url was unnecessarily formatted, allowing for possible information extraction.
Related
Alias · CVE (1)
- CVE-2022-40604 In Apache Airflow 2.3.0 through 2.3.4, part of a url was unnecessarily formatted, allowing for possible information extraction. vulnerability
Weakness · CWE (1)
- CWE-134 Use of Externally-Controlled Format String weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-40604 advisory
- https://github.com/apache/airflow/pull/26337 web
- https://github.com/apache/airflow/commit/18386026c28939fa6d91d198c5489c295a05dcd2 web
- https://github.com/apache/airflow/commit/6f24836e5ee56c452947aa87f84a21dd4f8eb87c web
- https://github.com/apache/airflow package
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2022-279.yaml web
- https://lists.apache.org/thread/z20x8m16fnhxdkoollv53w1ybsts687t web