GitHub Advisoryadvisory · PyPI
GHSA-5rpc-gwh9-q9fg Improper Restriction of Operations within the Bounds of a Memory Buffer in OpenCV
HIGH
Official page ↗
- Aliases
- CVE-2017-12862
- Ecosystem
- PyPI
- Packages
- opencv-python, opencv-contrib-python
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-119, CWE-787
- Reviewed
- 2021-10-07
Affected packages
• PyPI opencv-python: < 3.3.1.11 → fixed in 3.3.1.11
• PyPI opencv-contrib-python: < 3.3.1.11 → fixed in 3.3.1.11
Description
In modules/imgcodecs/src/grfmt_pxm.cpp, the length of buffer AutoBuffer _src is small than expected, which will cause copy buffer overflow later. If the image is from remote, may lead to remote code execution or denial of service. This affects OpenCV 3.3 (corresponding to OpenCV-Python 3.3.0.9) and earlier.
Related
Alias · CVE (1)
- CVE-2017-12862 In modules/imgcodecs/src/grfmt_pxm.cpp, the length of buffer AutoBuffer _src is small than expected, which will cause copy buffer overflow… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-12862 advisory
- https://github.com/opencv/opencv/issues/9370 web
- https://github.com/opencv/opencv/pull/9376 web
- https://github.com/opencv/opencv-python package
- https://lists.debian.org/debian-lts-announce/2018/07/msg00030.html web
- https://lists.debian.org/debian-lts-announce/2021/10/msg00028.html web
- https://security.gentoo.org/glsa/201712-02 web