GitHub Advisoryadvisory · PyPI

GHSA-5rrg-rr89-x9mv Ansible Exposes Sensitive Information

HIGH Published 2022-05-25 Modified 2024-09-09 Official page ↗
Aliases
CVE-2021-20228
Ecosystem
PyPI
Packages
ansible
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-200, CWE-522
Reviewed
2022-05-25

Affected packages

• PyPI ansible: >= 2.10.0a1, < 2.10.6rc1 → fixed in 2.10.6rc1 • PyPI ansible: >= 2.9.0a1, < 2.9.18rc1 → fixed in 2.9.18rc1 • PyPI ansible: < 2.8.19rc1 → fixed in 2.8.19rc1

Description

A flaw was found in the Ansible Engine prior to 2.10.6rc1, 2.9.18rc1, and 2.8.19rc1, where sensitive info is not masked by default and is not protected by the `no_log` feature when using the sub-option feature of the basic.py module. This flaw allows an attacker to obtain sensitive information. The highest threat from this vulnerability is to confidentiality.

Related

Alias · CVE (1)

  • CVE-2021-20228 A flaw was found in the Ansible Engine 2.9.18, where sensitive info is not masked by default and is not protected by the no_log feature… vulnerability

Weakness · CWE (2)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
  • CWE-522 Insufficiently Protected Credentials weakness

References