GitHub Advisoryadvisory · npm
GHSA-5v25-xr56-phph Clamscan vulnerable to command injection
HIGH
Official page ↗
- Aliases
- CVE-2020-7613
- Ecosystem
- npm
- Packages
- clamscan
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74, CWE-78
- Reviewed
- 2023-10-19
Affected packages
• npm clamscan: < 1.3.0 → fixed in 1.3.0
Description
clamscan through 1.2.0 is vulnerable to Command Injection. It is possible to inject arbitrary commands as part of the `_is_clamav_binary` function located within `Index.js`. It should be noted that this vulnerability requires a pre-requisite that a folder should be created with the same command that will be chained to execute. This lowers the risk of this issue.
Related
Alias · CVE (1)
- CVE-2020-7613 clamscan through 1.2.0 is vulnerable to Command Injection. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-7613 advisory
- https://github.com/kylefarris/clamscan/pull/45 web
- https://github.com/kylefarris/clamscan/commit/5f557c970817fe8c578ec3f7ad3bcbcef4cf5538 web
- https://github.com/kylefarris/clamscan package
- https://github.com/kylefarris/clamscan/blob/master/index.js#L34 web
- https://huntr.dev/bounties/1-npm-clamscan web
- https://snyk.io/vuln/SNYK-JS-CLAMSCAN-564113 web