GitHub Advisoryadvisory · npm
GHSA-5vj8-3v2h-h38v Remote Code Execution in next
HIGH
Official page ↗
- Ecosystem
- npm
- Packages
- next
- Severity
- High
- Weaknesses
- CWE-20
- Reviewed
- 2020-08-31
Affected packages
• npm next: >= 0.9.9, < 5.1.0 → fixed in 5.1.0
Description
Versions of `next` prior to 5.1.0 are vulnerable to Remote Code Execution. The `/path:` route fails to properly sanitize input and passes it to a `require()` call. This allows attackers to execute JavaScript code on the server. Note that prior version 0.9.9 package `next` npm package hosted a different utility (0.4.1 being the latest version of that codebase), and this advisory does not apply to those versions.
Recommendation
Upgrade to version 5.1.0.
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness