GitHub Advisoryadvisory · Packagist
GHSA-5w4h-xrr5-7273 Moodle Exposure of Sensitive Information to an Unauthorized Actor
MEDIUM
Official page ↗
- Aliases
- CVE-2018-10890
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2024-04-23
Affected packages
• Packagist moodle/moodle: >= 3.1, < 3.1.13 → fixed in 3.1.13
• Packagist moodle/moodle: >= 3.3, < 3.3.7 → fixed in 3.3.7
• Packagist moodle/moodle: >= 3.4, < 3.4.4 → fixed in 3.4.4
• Packagist moodle/moodle: >= 3.5, < 3.5.1 → fixed in 3.5.1
Description
A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. It was possible for the core_course_get_categories web service to return hidden categories, which should be omitted when fetching course categories.
Related
Alias · CVE (1)
- CVE-2018-10890 A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness