GitHub Advisoryadvisory · npm

GHSA-5wj5-87vq-39xm OpenClaw: Node Pairing Reconnect Command Escalation Bypasses operator.admin Scope Requirement

HIGH Published 2026-04-09 Modified 2026-06-08 Official page ↗
Aliases
CVE-2026-42432
Ecosystem
npm
Packages
openclaw
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-288, CWE-863
Reviewed
2026-04-09

Affected packages

• npm openclaw: < 2026.4.8 → fixed in 2026.4.8

Description

Impact Node Pairing Reconnect Command Escalation Bypasses operator.admin Scope Requirement. A previously paired node could reconnect with a broader command set, including exec-capable commands, without forcing the operator/admin re-pairing path. OpenClaw is a user-controlled local assistant. This advisory is scoped to the OpenClaw trust model and does not assume a multi-tenant service boundary. Affected Packages / Versions • Package: `openclaw` (npm) • Affected versions: `<=2026.4.5` • Patched versions: `2026.4.8` Fix The issue was fixed on `main` and is available in the patched npm version listed above. The verified fixed tree is commit `d7c3210cd6f5fdfdc1beff4c9541673e814354d5`. Verification The fix was re-checked against `main` before publication, including targeted regression tests for the affected security boundary. Credits Thanks @zsxsoft and @KeenSecurityLab for reporting.

Related

Alias · CVE (1)

  • CVE-2026-42432 OpenClaw before 2026.4.8 contains a privilege escalation vulnerability allowing previously paired nodes to reconnect with exec-capable… vulnerability

Weakness · CWE (2)

  • CWE-288 Authentication Bypass Using an Alternate Path or Channel weakness
  • CWE-863 Incorrect Authorization weakness

References