GitHub Advisoryadvisory · Packagist
GHSA-5wjh-v7c8-wrhx Moodle stored Cross-site Scripting
MEDIUM
Official page ↗
- Aliases
- CVE-2021-32475
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-04-23
Affected packages
• Packagist moodle/moodle: >= 3.5, < 3.5.18 → fixed in 3.5.18
• Packagist moodle/moodle: >= 3.8, < 3.8.9 → fixed in 3.8.9
• Packagist moodle/moodle: >= 3.9, < 3.9.7 → fixed in 3.9.7
• Packagist moodle/moodle: >= 3.10, < 3.10.4 → fixed in 3.10.4
Description
ID numbers displayed in the quiz grading report required additional sanitizing to prevent a stored XSS risk. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.
Related
Alias · CVE (1)
- CVE-2021-32475 ID numbers displayed in the quiz grading report required additional sanitizing to prevent a stored XSS risk. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness