GitHub Advisoryadvisory · Packagist

GHSA-5wm2-38q5-5rxv Several Zend Products Vulnerable to XXE and XEE attacks

MEDIUM Published 2022-05-14 Modified 2023-09-25 Official page ↗
Aliases
CVE-2014-2683
Ecosystem
Packagist
Packages
zendframework/zendframework1, zendframework/zendopenid, zendframework/zendrest, zendframework/zendservice-audioscrobbler, zendframework/zendservice-nirvanix, zendframework/zendservice-slideshare, zendframework/zendservice-technorati, zendframework/zendservice-windowsazure, zendframework/zendservice-amazon, zendframework/zendservice-api
Severity
Moderate
Weaknesses
CWE-611, CWE-776
Reviewed
2023-09-25

Affected packages

• Packagist zendframework/zendframework1: < 1.12.4 → fixed in 1.12.4 • Packagist zendframework/zendopenid: < 2.0.2 → fixed in 2.0.2 • Packagist zendframework/zendrest: < 2.0.2 → fixed in 2.0.2 • Packagist zendframework/zendservice-audioscrobbler: < 2.0.2 → fixed in 2.0.2 • Packagist zendframework/zendservice-nirvanix: < 2.0.2 → fixed in 2.0.2 • Packagist zendframework/zendservice-slideshare: < 2.0.2 → fixed in 2.0.2 • Packagist zendframework/zendservice-technorati: < 2.0.2 → fixed in 2.0.2 • Packagist zendframework/zendservice-windowsazure: < 2.0.2 → fixed in 2.0.2 • Packagist zendframework/zendservice-amazon: < 2.0.3 → fixed in 2.0.3 • Packagist zendframework/zendservice-api: < 1.0.0 → fixed in 1.0.0

Description

Zend Framework 1 (ZF1) before 1.12.4, Zend Framework 2 before 2.1.6 and 2.2.x before 2.2.6, ZendOpenId, ZendRest, ZendService_AudioScrobbler, ZendService_Nirvanix, ZendService_SlideShare, ZendService_Technorati, and ZendService_WindowsAzure before 2.0.2, ZendService_Amazon before 2.0.3, and ZendService_Api before 1.0.0 allow remote attackers to cause a denial of service (CPU consumption) via (1) recursive or (2) circular references in an XML entity definition in an XML DOCTYPE declaration, aka an XML Entity Expansion (XEE) attack. NOTE: this issue exists because of an incomplete fix for CVE-2012-6532.

Related

Alias · CVE (1)

  • CVE-2014-2683 Zend Framework 1 (ZF1) before 1.12.4, Zend Framework 2 before 2.1.6 and 2.2.x before 2.2.6, ZendOpenId, ZendRest,… vulnerability

Weakness · CWE (2)

  • CWE-611 Improper Restriction of XML External Entity Reference weakness
  • CWE-776 Improper Restriction of Recursive Entity References in DTDs weakness

References