GitHub Advisoryadvisory · Packagist
GHSA-5x28-3f32-x523 Drupal core Access control bypass
MEDIUM
Official page ↗
- Ecosystem
- Packagist
- Packages
- drupal/drupal
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Reviewed
- 2024-05-15
Affected packages
• Packagist drupal/drupal: >= 8.0.0, < 8.7.11 → fixed in 8.7.11
• Packagist drupal/drupal: >= 8.8.0, < 8.8.1 → fixed in 8.8.1
Description
The Media Library module has a security vulnerability whereby it doesn't sufficiently restrict access to media items in certain configurations.
Solution:
If you are using Drupal 8.7.x, you should upgrade to Drupal 8.7.11.
If you are using Drupal 8.8.x, you should upgrade to Drupal 8.8.1.
Versions of Drupal 8 prior to 8.7.x are end-of-life and do not receive security coverage.
Alternatively, you may mitigate this vulnerability by unchecking the "Enable advanced UI" checkbox on `/admin/config/media/media-library`. (This mitigation is not available in 8.7.x.)