GitHub Advisoryadvisory · Packagist
GHSA-5x33-h32w-6vr2 Cross site-scripting (XSS) moodle
MEDIUM
Official page ↗
- Aliases
- CVE-2020-25628
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2021-03-24
Affected packages
• Packagist moodle/moodle: >= 3.9.0, < 3.9.2 → fixed in 3.9.2
• Packagist moodle/moodle: >= 3.8.0, < 3.8.5 → fixed in 3.8.5
• Packagist moodle/moodle: >= 3.7.0, < 3.7.8 → fixed in 3.7.8
• Packagist moodle/moodle: >= 3.5, < 3.5.14 → fixed in 3.5.14
Description
The filter in the tag manager required extra sanitizing to prevent a reflected XSS risk. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.
Related
Alias · CVE (1)
- CVE-2020-25628 The filter in the tag manager required extra sanitizing to prevent a reflected XSS risk. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness