GitHub Advisoryadvisory · Go

GHSA-5x4g-q5rc-36jp Etcd pkg Insecure ciphers are allowed by default

LOW Published 2024-02-03 Modified 2024-07-08 Official page ↗
Ecosystem
Go
Packages
go.etcd.io/etcd/client/pkg/v3
Severity
Low
Reviewed
2024-02-03

Affected packages

• Go go.etcd.io/etcd/client/pkg/v3: >= 3.4.0-rc.0, < 3.4.10 → fixed in 3.4.10 • Go go.etcd.io/etcd/client/pkg/v3: < 3.3.23 → fixed in 3.3.23

Description

Vulnerability type Cryptography Detail The TLS ciphers list supported by etcd contains insecure cipher suites. Users can configure the desired ciphers using the “--cipher-suites” flag, and a default list of secure cipher suites is used if empty. Workarounds By default, no action is required. If users want to specify cipher suites using the '--cipher-suites' flag, they should try not to specify insecure cipher suites. Please refer to the security documentation. References Find out more on this vulnerability in the security audit report For more information If you have any questions or comments about this advisory: • Contact the etcd security committee

References