GitHub Advisoryadvisory · PyPI

GHSA-5xvc-vgmp-jgc3 Improper Access Control in jupyterhub-firstuseauthenticator

CRITICAL Published 2021-10-28 Modified 2024-09-24 Official page ↗
Aliases
CVE-2021-41194
Ecosystem
PyPI
Packages
jupyterhub-firstuseauthenticator
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-284
Reviewed
2021-10-28

Affected packages

• PyPI jupyterhub-firstuseauthenticator: < 1.0.0 → fixed in 1.0.0

Description

Impact When JupyterHub is used with FirstUseAuthenticator, the vulnerability allows unauthorized access to any user's account if `create_users=True` and the username is known or guessed. Patches Upgrade to jupyterhub-firstuseauthenticator to 1.0, or apply patch https://github.com/jupyterhub/firstuseauthenticator/pull/38.patch Workarounds If you cannot upgrade, there is no complete workaround, but it can be mitigated. If you cannot upgrade yet, you can disable user creation with `c.FirstUseAuthenticator.create_users = False`, which will only allow login with fully normalized usernames for already existing users prior to jupyterhub-firstuserauthenticator 1.0. If any users have never logged in with their normalized username (i.e. lowercase), they will still be vulnerable until you can patch or upgrade.

Related

Alias · CVE (1)

  • CVE-2021-41194 FirstUseAuthenticator is a JupyterHub authenticator that helps new users set their password on their first login to JupyterHub. vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References