GitHub Advisoryadvisory · npm

GHSA-6226-h7ff-ch6c Widget feature vulnerability allowing to execute JavaScript code using undo functionality

HIGH Published 2021-08-23 Modified 2022-02-08 Official page ↗
Aliases
CVE-2021-32808
Ecosystem
npm
Packages
ckeditor4
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N
Weaknesses
CWE-79
Reviewed
2021-08-23

Affected packages

• npm ckeditor4: >= 4.13.0, < 4.16.2 → fixed in 4.16.2

Description

Affected packages The vulnerability has been discovered in Widget plugin if used alongside Undo feature. Impact A potential vulnerability has been discovered in CKEditor 4 Widget package. The vulnerability allowed to abuse undo functionality using malformed widget HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version >= 4.13.0. Patches The problem has been recognized and patched. The fix will be available in version 4.16.2. For more information Email us at [email protected] if you have any questions or comments about this advisory. Acknowledgements The CKEditor 4 team would like to thank Anton Subbotin (skavans) for recognizing and reporting this vulnerability.

Related

Alias · CVE (1)

  • CVE-2021-32808 ckeditor is an open source WYSIWYG HTML editor with rich content support. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References