GitHub Advisoryadvisory · Maven
GHSA-62pm-mgrh-7p69 Incorrect Authorization in Jenkins Script Security Plugin
HIGH
Official page ↗
- Aliases
- CVE-2019-16538
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:script-security
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-863
- Reviewed
- 2022-06-27
Affected packages
• Maven org.jenkins-ci.plugins:script-security: < 1.68 → fixed in 1.68
Description
A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.67 and earlier related to the handling of default parameter expressions in closures allowed attackers to execute arbitrary code in sandboxed scripts.
Related
Alias · CVE (1)
- CVE-2019-16538 A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.67 and earlier related to the handling of default parameter expressions… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness