GitHub Advisoryadvisory · Maven
GHSA-62wf-24c4-8r76 Cross-site Scripting vulnerability in Jenkins
HIGH
Official page ↗
- Aliases
- CVE-2022-34170
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-22, CWE-79
- Reviewed
- 2022-12-06
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: >= 2.350, < 2.356 → fixed in 2.356
• Maven org.jenkins-ci.main:jenkins-core: >= 2.320, < 2.332.4 → fixed in 2.332.4
• Maven org.jenkins-ci.main:jenkins-core: >= 2.346, < 2.346.1 → fixed in 2.346.1
Description
Since Jenkins 2.320 and LTS 2.332.1, help icon tooltips no longer escape the feature name, effectively undoing the fix for SECURITY-1955.
This vulnerability is known to be exploitable by attackers with Job/Configure permission.
Jenkins 2.356, LTS 2.332.4 and LTS 2.346.1 addresses this vulnerability, the feature name in help icon tooltips is now escaped.
Related
Alias · CVE (1)
- CVE-2022-34170 In Jenkins 2.320 through 2.355 (both inclusive) and LTS 2.332.1 through LTS 2.332.3 (both inclusive) the help icon does not escape the… vulnerability