GitHub Advisoryadvisory · Packagist

GHSA-62wh-m4jr-233r Moodle LTI module reflected XSS risk

MEDIUM Published 2022-07-26 Modified 2024-04-24 Official page ↗
Aliases
CVE-2022-35653
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-04-24

Affected packages

• Packagist moodle/moodle: >= 4.0, < 4.0.2 → fixed in 4.0.2 • Packagist moodle/moodle: >= 3.11, < 3.11.8 → fixed in 3.11.8 • Packagist moodle/moodle: >= 3.9, < 3.9.15 → fixed in 3.9.15

Description

A reflected XSS issue was identified in the LTI module of Moodle. The vulnerability exists due to insufficient sanitization of user-supplied data in the LTI module. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks. This vulnerability does not impact authenticated users.

Related

Alias · CVE (1)

  • CVE-2022-35653 A reflected XSS issue was identified in the LTI module of Moodle. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References