GitHub Advisoryadvisory · Packagist

GHSA-62wv-866c-rh86 Moodle does not properly restrict comment capabilities

MEDIUM Published 2022-05-13 Modified 2025-04-12 Official page ↗
Aliases
CVE-2011-4297
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U
Weaknesses
CWE-863
Reviewed
2025-04-12

Affected packages

• Packagist moodle/moodle: >= 2.0.0, < 2.0.4 → fixed in 2.0.4 • Packagist moodle/moodle: >= 2.1.0, < 2.1.1 → fixed in 2.1.1

Description

comment/lib.php in Moodle 2.0.x before 2.0.4 and 2.1.x before 2.1.1 does not properly restrict comment capabilities, which allows remote attackers to post a comment by leveraging the guest role and operating on a front-page activity.

Related

Alias · CVE (1)

  • CVE-2011-4297 comment/lib.php in Moodle 2.0.x before 2.0.4 and 2.1.x before 2.1.1 does not properly restrict comment capabilities, which allows remote… vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References