GitHub Advisoryadvisory · Packagist

GHSA-634x-pc3q-cf4c PHP Code Injection by malicious block or filename in Smarty

HIGH Published 2022-05-25 Modified 2022-06-07 Official page ↗
Aliases
CVE-2022-29221
Ecosystem
Packagist
Packages
smarty/smarty
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2022-05-25

Affected packages

• Packagist smarty/smarty: < 3.1.45 → fixed in 3.1.45 • Packagist smarty/smarty: >= 4.0.0, < 4.1.1 → fixed in 4.1.1

Description

Impact Template authors could inject php code by choosing a malicous {block} name or {include} file name. Sites that cannot fully trust template authors should update asap. Patches Please upgrade to the most recent version of Smarty v3 or v4. Workarounds _Is there a way for users to fix or remediate the vulnerability without upgrading?_ References _Are there any links users can visit to find out more?_ For more information If you have any questions or comments about this advisory: • Open an issue in the Smarty repo

Related

Alias · CVE (1)

  • CVE-2022-29221 Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References