GitHub Advisoryadvisory · Go

GHSA-6362-gv4m-53ww Calico privilege escalation vulnerability

HIGH Published 2024-04-30 Modified 2024-11-18 Official page ↗
Aliases
CVE-2024-33522
Ecosystem
Go
Packages
github.com/projectcalico/calico
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-269
Reviewed
2024-06-10

Affected packages

• Go github.com/projectcalico/calico: < 3.26.5 → fixed in 3.26.5 • Go github.com/projectcalico/calico: >= 3.27.0, < 3.27.3 → fixed in 3.27.3

Description

In vulnerable versions of Calico (v3.27.2 and below), Calico Enterprise (v3.19.0-1, v3.18.1, v3.17.3 and below), and Calico Cloud (v19.2.0 and below), an attacker who has local access to the Kubernetes node, can escalate their privileges by exploiting a vulnerability in the Calico CNI install binary. The issue arises from an incorrect SUID (Set User ID) bit configuration in the binary, combined with the ability to control the input binary, allowing an attacker to execute an arbitrary binary with elevated privileges.

Related

Alias · CVE (1)

  • CVE-2024-33522 In vulnerable versions of Calico (v3.27.2 and below), Calico Enterprise (v3.19.0-1, v3.18.1, v3.17.3 and below), and Calico Cloud (v19.2.0… vulnerability

Weakness · CWE (1)

  • CWE-269 Improper Privilege Management weakness

References