GitHub Advisoryadvisory · Maven
GHSA-644j-jcc4-crx7 Jenkins AWS CodeDeploy Plugin has Insufficiently Protected Credentials
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1000402
- Ecosystem
- Maven
- Packages
- com.amazonaws:codedeploy
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-522
- Reviewed
- 2022-11-08
Affected packages
• Maven com.amazonaws:codedeploy: < 1.20 → fixed in 1.20
Description
Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a File and Directory Information Exposure vulnerability in AWSCodeDeployPublisher.java that can result in Disclosure of environment variables. This vulnerability appears to have been fixed in 1.20 and later.
Related
Alias · CVE (1)
- CVE-2018-1000402 Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a File and Directory Information Exposure vulnerability in… vulnerability
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000402 advisory
- https://github.com/jenkinsci/aws-codedeploy-plugin/commit/4bef70636dbcb9e773d4a4a6186726719cb88ee4 web
- https://github.com/jenkinsci/aws-codedeploy-plugin/commit/a086092ddf79d0b232e44f5908e8b6ef3dfcde9d web
- https://jenkins.io/security/advisory/2018-06-25/#SECURITY-825 web