GitHub Advisoryadvisory · npm

GHSA-6465-jgvq-jhgp Sentry's sensitive headers are leaked when `sendDefaultPii` is set to `true`

MEDIUM Published 2025-11-24 Modified 2025-11-27 Official page ↗
Aliases
CVE-2025-65944
Ecosystem
npm
Packages
@sentry/node, @sentry/astro, @sentry/aws-serverless, @sentry/bun, @sentry/google-cloud-serverless, @sentry/nestjs, @sentry/nextjs, @sentry/node-core, @sentry/nuxt, @sentry/remix, @sentry/solidstart, @sentry/sveltekit
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:L
Weaknesses
CWE-201
Reviewed
2025-11-24

Affected packages

• npm @sentry/node: >= 10.11.0, < 10.27.0 → fixed in 10.27.0 • npm @sentry/astro: >= 10.11.0, < 10.27.0 → fixed in 10.27.0 • npm @sentry/aws-serverless: >= 10.11.0, < 10.27.0 → fixed in 10.27.0 • npm @sentry/bun: >= 10.11.0, < 10.27.0 → fixed in 10.27.0 • npm @sentry/google-cloud-serverless: >= 10.11.0, < 10.27.0 → fixed in 10.27.0 • npm @sentry/nestjs: >= 10.11.0, < 10.27.0 → fixed in 10.27.0 • npm @sentry/nextjs: >= 10.11.0, < 10.27.0 → fixed in 10.27.0 • npm @sentry/node-core: >= 10.11.0, < 10.27.0 → fixed in 10.27.0 • npm @sentry/nuxt: >= 10.11.0, < 10.27.0 → fixed in 10.27.0 • npm @sentry/remix: >= 10.11.0, < 10.27.0 → fixed in 10.27.0 • npm @sentry/solidstart: >= 10.11.0, < 10.27.0 → fixed in 10.27.0 • npm @sentry/sveltekit: >= 10.11.0, < 10.27.0 → fixed in 10.27.0

Description

Impact In version 10.11.0, a change to how the SDK collects request data in Node.js applications caused certain incoming HTTP headers to be added as trace span attributes. When `sendDefaultPii: true` was set, a few headers that were previously redacted - including Authorization and Cookie - were unintentionally allowed through. Sentry’s server-side scrubbing (handled by Sentry's Relay edge proxy) normally serves as a second layer of protection. However, because it relied on the same matching logic as the SDK, it also failed to catch these headers in this case. Users may be impacted if: 1. Their Sentry SDK configuration has `sendDefaultPii` set to `true` 2. Their application uses one of the Node.js Sentry SDKs with version from `10.11.0` to `10.26.0` inclusively: • @sentry/astro • @sentry/aws-serverless • @sentry/bun • @sentry/google-cloud-serverless • @sentry/nestjs • @sentry/nextjs • @sentry/node • @sentry/node-core • @sentry/nuxt • @sentry/remix • @sentry/solidstart • @sentry/sveltekit Users can check if their project was affected, by visiting Explore → Traces and searching for “http.request.header.authorization”, “http.request.header.cookie” or similar. Any potentially sensitive values will be specific to users' applications and configurations. Patches The issue has been patched in all Sentry JavaScript SDKs starting from the 10.27.0 version. Workarounds Sentry strongly encourage customers to upgrade the SDK to the latest available version, 10.27.0 or later. If it is not possible, consider setting `sendDefaultPii: false` to avoid unintentionally sending sensitive headers. See here for documentation. Resources • https://develop.sentry.dev/sdk/expected-features/data-handling/#sensitive-data • https://github.com/getsentry/sentry-javascript/releases/tag/10.11.0 • https://github.com/getsentry/sentry-javascript/pull/17475 • https://docs.sentry.io/platforms/javascript/guides/node/data-management/data-collected/#cookies

Related

Alias · CVE (1)

  • CVE-2025-65944 Sentry-Javascript is an official Sentry SDKs for JavaScript. vulnerability

Weakness · CWE (1)

  • CWE-201 Insertion of Sensitive Information Into Sent Data weakness

References