GitHub Advisoryadvisory · PyPI
GHSA-647r-72hf-4vmh Code Index MCP is vulnerable to Uncontrolled Resource Consumption
LOW
Official page ↗
- Aliases
- CVE-2026-10692
- Ecosystem
- PyPI
- Packages
- code-index-mcp
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-400
- Reviewed
- 2026-07-10
Affected packages
• PyPI code-index-mcp: < 2.14.1 → fixed in 2.14.1
Description
A weakness has been identified in johnhuang316 code-index-mcp up to 2.14.0. Affected is the function is_safe_regex_pattern of the component search_code_advanced. Executing a manipulation of the argument regex can lead to inefficient regular expression complexity. It is possible to launch the attack remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 2.14.1 is able to address this issue. This patch is called 25bc02fac74051ddae15ce79e952f00211b1ea6b. Upgrading the affected component is recommended.
Related
Alias · CVE (1)
- CVE-2026-10692 A weakness has been identified in johnhuang316 code-index-mcp up to 2.14.0. vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-10692 advisory
- https://github.com/johnhuang316/code-index-mcp/issues/84 web
- https://github.com/johnhuang316/code-index-mcp/commit/25bc02fac74051ddae15ce79e952f00211b1ea6b web
- https://github.com/johnhuang316/code-index-mcp package
- https://github.com/johnhuang316/code-index-mcp/releases/tag/v2.14.1 web
- https://vuldb.com/cve/CVE-2026-10692 web
- https://vuldb.com/submit/830786 web
- https://vuldb.com/vuln/367961 web
- https://vuldb.com/vuln/367961/cti web