GitHub Advisoryadvisory · PyPI

GHSA-6565-fg86-6jcx Django Cross-site Scripting Vulnerability

MEDIUM Published 2022-05-17 Modified 2024-09-18 Official page ↗
Aliases
CVE-2015-2241
Ecosystem
PyPI
Packages
Django
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-08-04

Affected packages

• PyPI Django: < 1.7.6 → fixed in 1.7.6 • PyPI Django: >= 1.8a1, < 1.8b2 → fixed in 1.8b2

Description

Cross-site scripting (XSS) vulnerability in the contents function in `admin/helpers.py` in Django before 1.7.6 and 1.8 before 1.8b2 allows remote attackers to inject arbitrary web script or HTML via a model attribute in `ModelAdmin.readonly_fields`, as demonstrated by an `@property`.

Related

Alias · CVE (1)

  • CVE-2015-2241 Cross-site scripting (XSS) vulnerability in the contents function in admin/helpers.py in Django before 1.7.6 and 1.8 before 1.8b2 allows… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References