GitHub Advisoryadvisory · Maven
GHSA-65vg-64g8-mwjr Apache Seata Vulnerable to Data Amplification
LOW
Official page ↗
- Aliases
- CVE-2024-54016
- Ecosystem
- Maven
- Packages
- org.apache.seata:seata-parent
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-409
- Reviewed
- 2025-03-20
Affected packages
• Maven org.apache.seata:seata-parent: >= 2.0.0, < 2.3.0 → fixed in 2.3.0
Description
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Seata (incubating).
This issue affects Apache Seata (incubating): through <=2.2.0.
Users are recommended to upgrade to version 2.3.0, which fixes the issue.
Related
Alias · CVE (1)
- CVE-2024-54016 Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Seata (incubating). vulnerability
Weakness · CWE (1)
- CWE-409 Improper Handling of Highly Compressed Data (Data Amplification) weakness