GitHub Advisoryadvisory · PyPI
GHSA-65xw-pcqw-hjrh Apache Airflow Cross-site Scripting Vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2021-45229
- Ecosystem
- PyPI
- Packages
- apache-airflow
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-03-01
Affected packages
• PyPI apache-airflow: < 2.2.4rc1 → fixed in 2.2.4rc1
Description
It was discovered that the "Trigger DAG with config" screen was susceptible to XSS attacks via the `origin` query argument. This issue affects Apache Airflow versions 2.2.3 and below.
Related
Alias · CVE (1)
- CVE-2021-45229 It was discovered that the "Trigger DAG with config" screen was susceptible to XSS attacks via the `origin` query argument. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-45229 advisory
- https://github.com/apache/airflow/commit/628aa1f99c865d97d0b1c7c76e630e43a7b8d319 web
- https://github.com/advisories/GHSA-65xw-pcqw-hjrh advisory
- https://github.com/apache/airflow package
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2022-29.yaml web
- https://lists.apache.org/thread/phx76cgtmhwwdy780rvwhobx8qoy4bnk web