GitHub Advisoryadvisory · Maven, PyPI, RubyGems

GHSA-6628-q6j9-w8vg gRPC Reachable Assertion issue

HIGH Published 2023-07-06 Modified 2025-08-13 Official page ↗
Aliases
CVE-2023-1428
Ecosystem
Maven, PyPI, RubyGems
Packages
io.grpc:grpc-protobuf, grpcio, grpc
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-617
Reviewed
2023-07-06

Affected packages

• Maven io.grpc:grpc-protobuf: >= 1.51.0, < 1.53.0 → fixed in 1.53.0 • PyPI grpcio: >= 1.51.0, < 1.53.0 → fixed in 1.53.0 • RubyGems grpc: >= 1.51.0, < 1.53.0 → fixed in 1.53.0

Description

There exists an vulnerability causing an abort() to be called in gRPC.  The following headers cause gRPC's C++ implementation to abort() when called via http2: te: x (x != trailers) :scheme: x (x != http, https) grpclb_client_stats: x (x == anything) On top of sending one of those headers, a later header must be sent that gets the total header size past 8KB. We recommend upgrading past git commit 2485fa94bd8a723e5c977d55a3ce10b301b437f8 or v1.53 and above.

Related

Alias · CVE (1)

  • CVE-2023-1428 There exists an vulnerability causing an abort() to be called in gRPC. vulnerability

Weakness · CWE (1)

  • CWE-617 Reachable Assertion weakness

References