GitHub Advisoryadvisory · Packagist

GHSA-664q-mrxx-2x2v Moodle does not properly manage privileges for WebDAV repositories

MEDIUM Published 2022-05-13 Modified 2024-01-22 Official page ↗
Aliases
CVE-2013-1836
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Reviewed
2024-01-22

Affected packages

• Packagist moodle/moodle: >= 2.0.0, < 2.2.8 → fixed in 2.2.8 • Packagist moodle/moodle: >= 2.3.0, < 2.3.5 → fixed in 2.3.5 • Packagist moodle/moodle: >= 2.4.0, < 2.4.2 → fixed in 2.4.2

Description

Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 does not properly manage privileges for WebDAV repositories, which allows remote authenticated users to read, modify, or delete arbitrary site-wide repositories by leveraging certain read access.

Related

Alias · CVE (1)

  • CVE-2013-1836 Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 does not properly manage privileges for WebDAV… vulnerability

References