GitHub Advisoryadvisory · Packagist

GHSA-6656-6qwx-4c2m Moodle XSS In Tag Autocomplete functionality

MEDIUM Published 2022-05-13 Modified 2024-01-17 Official page ↗
Aliases
CVE-2011-4278
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2024-01-17

Affected packages

• Packagist moodle/moodle: < 1.9.11 → fixed in 1.9.11 • Packagist moodle/moodle: >= 2.0, < 2.0.2 → fixed in 2.0.2

Description

Cross-site scripting (XSS) vulnerability in the tag autocomplete functionality in Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Related

Alias · CVE (1)

  • CVE-2011-4278 Cross-site scripting (XSS) vulnerability in the tag autocomplete functionality in Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 allows… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References