GitHub Advisoryadvisory · npm

GHSA-6677-83pp-f862 Cross-Site Scripting in @nuxt/devalue

MEDIUM Published 2019-07-16 Modified 2021-08-17 Official page ↗
Aliases
CVE-2019-13506
Ecosystem
npm
Packages
@nuxt/devalue
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2019-07-15

Affected packages

• npm @nuxt/devalue: < 1.2.3 → fixed in 1.2.3

Description

Versions of `@nuxt/devalue` prior to 1.2.3 are vulnerable to Cross-Site Scripting. Due to insufficient input sanitization attacker may inject arbitrary JavaScript code through object keys. Recommendation Upgrade to version 1.2.3 or later.

Related

Alias · CVE (1)

  • CVE-2019-13506 @nuxt/devalue before 1.2.3, as used in Nuxt.js before 2.6.2, mishandles object keys, leading to XSS. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References