GitHub Advisoryadvisory · PyPI
GHSA-66vj-393f-hxfv OpenStack Swift Cross-site Scriping vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2014-3497
- Ecosystem
- PyPI
- Packages
- swift
- Severity
- Moderate
- Weaknesses
- CWE-79
- Reviewed
- 2023-02-08
Affected packages
• PyPI swift: >= 1.11.0, < 2.0.0 → fixed in 2.0.0
Description
Cross-site scripting (XSS) vulnerability in OpenStack Swift 1.11.0 through 1.13.1 allows remote attackers to inject arbitrary web script or HTML via the WWW-Authenticate header.
Related
Alias · CVE (1)
- CVE-2014-3497 Cross-site scripting (XSS) vulnerability in OpenStack Swift 1.11.0 through 1.13.1 allows remote attackers to inject arbitrary web script or… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2014-3497 advisory
- https://access.redhat.com/errata/RHSA-2014:0941 web
- https://access.redhat.com/security/cve/CVE-2014-3497 web
- https://bugzilla.redhat.com/show_bug.cgi?id=1110809 web
- https://opendev.org/openstack/swift package
- https://review.openstack.org/#/c/101031 web
- https://review.openstack.org/#/c/101032 web
- https://web.archive.org/web/20200229060002/http://www.securityfocus.com/bid/68116 web
- http://lists.openstack.org/pipermail/openstack-announce/2014-June/000243.html web
- http://www.openwall.com/lists/oss-security/2014/06/19/10 web
- http://www.ubuntu.com/usn/USN-2256-1 web