GitHub Advisoryadvisory · Packagist
GHSA-673x-f5wx-fxpw Cross Site Scripting and RCE in baserCMS
LOW
Official page ↗
- Aliases
- CVE-2020-15159
- Ecosystem
- Packagist
- Packages
- baserproject/basercms
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2020-08-28
Affected packages
• Packagist baserproject/basercms: >= 4.0.0, < 4.3.7 → fixed in 4.3.7
Description
baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS) and Remote Code Execution (RCE).
• Impact: XSS to RCE via Arbitrary file upload.
• Attack vector is: Administrator must be logged in.
• Components are: ThemeFilesController.php, UploaderFilesController.php.
• Tested baserCMS Version : 4.3.6 (Latest)
• Affected baserCMS Version : 4.2.0 ~ 4.3.6 (XSS), 3.0.10 ~ 4.3.6 (RCE)
• Patches : https://basercms.net/security/20200827
Found by Vulnerability Research team in Flatt Security Inc.
Related
Alias · CVE (1)
- CVE-2020-15159 baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS) and Remote Code Execution (RCE). vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness