GitHub Advisoryadvisory · PyPI

GHSA-6757-jp84-gxfx Improper Input Validation in PyYAML

CRITICAL Published 2021-04-20 Modified 2024-10-31 Official page ↗
Aliases
CVE-2020-1747
Ecosystem
PyPI
Packages
pyyaml
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20
Reviewed
2021-04-07

Affected packages

• PyPI pyyaml: >= 5.1b7, < 5.3.1 → fixed in 5.3.1

Description

A vulnerability was discovered in the PyYAML library in versions before 5.3.1, where it is susceptible to arbitrary code execution when it processes untrusted YAML files through the full_load method or with the FullLoader loader. Applications that use the library to process untrusted input may be vulnerable to this flaw. An attacker could use this flaw to execute arbitrary code on the system by abusing the python/object/new constructor.

Related

Alias · CVE (1)

  • CVE-2020-1747 A vulnerability was discovered in the PyYAML library in versions before 5.3.1, where it is susceptible to arbitrary code execution when it… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References