GitHub Advisoryadvisory · PyPI
GHSA-67c5-x5mf-rppq MLflow: Improper Origin Validation in MLflow Assistant /ajax-api Endpoints Enables Browser-Mediated Local Command Execution
CRITICAL
Official page ↗
- Aliases
- CVE-2026-2611
- Ecosystem
- PyPI
- Packages
- mlflow
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-346, CWE-940
- Reviewed
- 2026-06-04
Affected packages
• PyPI mlflow: >= 3.9.0, < 3.10.0 → fixed in 3.10.0
Description
In MLflow version 3.9.0, the MLflow Assistant feature introduced improper origin validation in its /ajax-api endpoints. This vulnerability allows a remote attacker to exploit cross-origin requests from a malicious webpage to interact with the MLflow Assistant running on a victim's local machine. By bypassing the loopback-only restriction, the attacker can modify the Assistant's configuration to enable full access, which in turn allows the execution of arbitrary commands via the Claude Code sub-agent. This issue is resolved in version 3.10.0.
Related
Alias · CVE (1)
- CVE-2026-2611 In MLflow version 3.9.0, the MLflow Assistant feature introduced improper origin validation in its /ajax-api endpoints. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-2611 advisory
- https://github.com/mlflow/mlflow/commit/8f9c8a53af90842944101eb8b7d60706822c81bc web
- https://access.redhat.com/security/cve/CVE-2026-2611 web
- https://bugzilla.redhat.com/show_bug.cgi?id=2479797 web
- https://github.com/advisories/GHSA-67c5-x5mf-rppq advisory
- https://github.com/mlflow/mlflow package
- https://github.com/pypa/advisory-database/tree/main/vulns/mlflow/PYSEC-2026-418.yaml web
- https://huntr.com/bounties/8462addd-b464-4a84-b6a2-5529604e6e5a web
- https://pypi.org/project/mlflow web