GitHub Advisoryadvisory · PyPI
GHSA-67cx-rhhq-mfhq High severity vulnerability that affects indico
HIGH
Official page ↗
- Ecosystem
- PyPI
- Packages
- indico
- Severity
- High
- Weaknesses
- CWE-77
- Reviewed
- 2020-06-16
Affected packages
• PyPI indico: < 2.1.10 → fixed in 2.1.10
• PyPI indico: >= 2.2.0, < 2.2.3 → fixed in 2.2.3
Description
Local file disclosure through LaTeX injection
Impact
An external audit of the Indico codebase has discovered a vulnerability in Indico's LaTeX sanitization code, which could have malicious users to run unsafe LaTeX commands on the server. Such commands allowed for example to read local files (e.g. `indico.conf`).
As far as we know it is not possible to write files or execute code using this vulnerability.
Patches
You need to update to Indico 2.2.3 as soon as possible.
We also released Indico 2.1.10 in case you cannot update to 2.2 for some reason.
See https://docs.getindico.io/en/stable/installation/upgrade/ for instructions on how to update.
Workarounds
Setting `XELATEX_PATH = None` in `indico.conf` will result in an error when building a PDF, but without being able to run xelatex, the vulnerability cannot be abused.
For more information
If you have any questions or comments about this advisory:
• Open a thread in our forum
• Email us privately at [email protected]
Related
Weakness · CWE (1)
- CWE-77 Improper Neutralization of Special Elements used in a Command weakness