GitHub Advisoryadvisory · npm

GHSA-67j4-2mh6-8627 json-logic-js Command Injection vulnerability

CRITICAL Published 2023-03-05 Modified 2024-09-23 Official page ↗
Aliases
CVE-2021-4329
Ecosystem
npm
Packages
json-logic-js
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-77
Reviewed
2023-03-07

Affected packages

• npm json-logic-js: < 2.0.1 → fixed in 2.0.1

Description

A vulnerability, which was classified as critical, has been found in json-logic-js 2.0.0. Affected by this issue is some unknown functionality of the file logic.js. The manipulation leads to command injection. Upgrading to version 2.0.1 is able to address this issue. The name of the patch is c1dd82f5b15d8a553bb7a0cfa841ab8a11a9c227. It is recommended to upgrade the affected component. VDB-222266 is the identifier assigned to this vulnerability.

Related

Alias · CVE (1)

  • CVE-2021-4329 A vulnerability, which was classified as critical, has been found in json-logic-js 2.0.0. vulnerability

Weakness · CWE (1)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness

References