GitHub Advisoryadvisory · npm

GHSA-67mf-f936-ppxf OpenClaw `node.pair.approve` placed in `operator.write` scope instead of `operator.pairing` allows unprivileged pairing approval

MEDIUM Published 2026-04-09 Modified 2026-05-06 Official page ↗
Aliases
CVE-2026-42426
Ecosystem
npm
Packages
openclaw
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-269, CWE-863
Reviewed
2026-04-09

Affected packages

• npm openclaw: < 2026.4.8 → fixed in 2026.4.8

Description

Impact OpenClaw `node.pair.approve` placed in `operator.write` scope instead of `operator.pairing` allows unprivileged pairing approval. The pairing approval method accepted operator.write instead of the narrower pairing scope and admin requirement for exec-capable nodes. OpenClaw is a user-controlled local assistant. This advisory is scoped to the OpenClaw trust model and does not assume a multi-tenant service boundary. Affected Packages / Versions • Package: `openclaw` (npm) • Affected versions: `<= v2026.04.01` • Patched versions: `2026.4.8` Fix The issue was fixed on `main` and is available in the patched npm version listed above. The verified fixed tree is commit `d7c3210cd6f5fdfdc1beff4c9541673e814354d5`. Verification The fix was re-checked against `main` before publication, including targeted regression tests for the affected security boundary. Credits Thanks @nicky-cc of Tencent zhuque Lab (https://github.com/Tencent/AI-Infra-Guard) for reporting.

Related

Alias · CVE (1)

  • CVE-2026-42426 OpenClaw before 2026.4.8 contains an improper authorization vulnerability where the node.pair.approve method accepts operator.write scope… vulnerability

Weakness · CWE (2)

  • CWE-269 Improper Privilege Management weakness
  • CWE-863 Incorrect Authorization weakness

References