GitHub Advisoryadvisory · PyPI
GHSA-6859-2qxq-ffv2 pgadmin4 is affected by a Cross-Origin Opener Policy (COOP) vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2025-9636
- Ecosystem
- PyPI
- Packages
- pgadmin4
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:L
- Weaknesses
- CWE-346
- Reviewed
- 2025-09-05
Affected packages
• PyPI pgadmin4: < 9.8 → fixed in 9.8
Description
pgAdmin <= 9.7 is affected by a Cross-Origin Opener Policy (COOP) vulnerability. This vulnerability allows an attacker to manipulate the OAuth flow, potentially leading to unauthorised account access, account takeover, data breaches, and privilege escalation.
Related
Alias · CVE (1)
- CVE-2025-9636 pgAdmin <= 9.7 is affected by a Cross-Origin Opener Policy (COOP) vulnerability. vulnerability
Weakness · CWE (1)
- CWE-346 Origin Validation Error weakness