GitHub Advisoryadvisory · npm
GHSA-686g-3xr3-x4x6 Information Exposure on Case Insensitive File Systems in serve
MEDIUM
Official page ↗
- Aliases
- CVE-2018-3809
- Ecosystem
- npm
- Packages
- serve
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2020-06-16
Affected packages
• npm serve: < 7.0.0 → fixed in 7.0.0
Description
Versions of `serve` before 7.0.0 are vulnerable to information exposure, bypassing the ignore security control, but only on case insensitive file systems.
Recommendation
Update to version 7.0.0 or later.
Related
Alias · CVE (1)
- CVE-2018-3809 Information exposure through directory listings in serve 6.5.3 allows directory listing and file access even when they have been set to be… vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness