GitHub Advisoryadvisory · PyPI
GHSA-6875-ff47-r6p6 Ipsilon denial of service via a duplicate SP name
MEDIUM
Official page ↗
- Aliases
- CVE-2015-5217
- Ecosystem
- PyPI
- Packages
- ipsilon
- Severity
- Moderate
- Reviewed
- 2024-11-22
Affected packages
• PyPI ipsilon: >= 0.1.0, < 1.2.0 → fixed in 1.2.0
Description
providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.1 does not properly check permissions to update the SAML2 Service Provider (SP) owner, which allows remote authenticated users to cause a denial of service via a duplicate SP name.
Related
Alias · CVE (1)
- CVE-2015-5217 providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.1 does not properly check permissions to update… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-5217 advisory
- https://bugzilla.redhat.com/show_bug.cgi?id=1255172 web
- https://fedorahosted.org/ipsilon/wiki/Releases/v1.0.1 web
- https://github.com/ipsilon-project/ipsilon package
- https://github.com/pypa/advisory-database/tree/main/vulns/ipsilon/PYSEC-2015-41.yaml web
- https://pagure.io/ipsilon/826e6339441546f596320f3d73304ab5f7c10de6 web
- http://www.openwall.com/lists/oss-security/2015/10/27/8 web