GitHub Advisoryadvisory · Packagist

GHSA-688p-pgj4-77hh Moodle allows attackers to obtain sensitive course-structure information

MEDIUM Published 2022-05-13 Modified 2024-01-26 Official page ↗
Aliases
CVE-2015-3180
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Weaknesses
CWE-200
Reviewed
2024-01-26

Affected packages

• Packagist moodle/moodle: < 2.6.11 → fixed in 2.6.11 • Packagist moodle/moodle: >= 2.7.0, < 2.7.8 → fixed in 2.7.8 • Packagist moodle/moodle: >= 2.8.0, < 2.8.6 → fixed in 2.8.6

Description

lib/navigationlib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to obtain sensitive course-structure information by leveraging access to a student account with a suspended enrolment.

Related

Alias · CVE (1)

  • CVE-2015-3180 lib/navigationlib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated… vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References